Issues with RocketReach API
Resolved·Degraded performance

We have resolved the intermittent timeouts with RocketReach search. We apologize for any inconvenience this caused.

Fri, Jun 20, 2025, 08:12 PM
(1 week ago)
·
Affected components
API
Updates

Resolved

We have resolved the intermittent timeouts with RocketReach search. We apologize for any inconvenience this caused.

Fri, Jun 20, 2025, 08:12 PM

Monitoring

We have implemented multiple fixes for the reliability issues with search via the the RocketReach API and are currently monitoring. We will provide updates once the issue is fully resolved. We apologize for any inconvenience this caused.

Fri, Jun 13, 2025, 09:33 PM(6 days earlier)

Investigating

We are researching the cause of intermittent timeouts with search via the RocketReach API. We'll provide an update as soon as possible.

Thu, Jun 12, 2025, 07:15 PM(1 day earlier)
Powered by