Resolved
RocketReach applications have been restored to normal operations. We will continue to monitor site performance as we recover from the degraded experience.
Investigating
RocketReach applications are currently seeing a degraded performance. You may notice slow response times or errors being returned from the application. We are actively working on identifying the source of the degradation.