Resolved
We have resolved the issue with the RocketReach platform and are currently monitoring. We apologize for any inconvenience this caused.
Monitoring
Service has been restored across RocketReach, the Extension, API, and MCP. We are actively monitoring performance to ensure it remains stable.
Investigating
Some customers may experience errors or slow loading in RocketReach. We are investigating elevated error rates and are working to restore normal performance.